System slowness or unresponsiveness can be the result of many reasons including hardware, connectivity or the Internet browser. 

If you are using Internet Explorer version 10 or older, you will need to upgrade your browser to version 11. However, if you are unable to upgrade, we suggest you install and use a different browser such as Firefox, Google Chrome, or Safari.

Beginning June 4, 2016, Employee Self Service will no longer support older browsers including Internet Explorer 9 and 10, Google Chrome 35, Firefox 24, and Safari 6 for Mac.

To confirm your Internet browser version:

  • Open Internet Explorer on your PC or laptop
  • Click on the “Help” option in the menu bar located at the top of your screen. If the menu bar is not shown, press “F10” to toggle the bar.
  • Select “About Internet Explorer”.  The pop-up will display the browser version and other information

Solution:  If your browser is an older version, complete one of the following actions:

State issued Computer: Contact your agency IT support to request an update of your Internet Browser.  Follow local agency policies and procedures.

Personal Computer:  Install Firefox, Chrome or Safari on your computer by choosing the appropriate link below and following the instructions.

Install Firefox

Install Google Chrome

Install Safari