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OneDrive for Business - General 

What is OneDrive for Business?   
OneDrive for Business is a cloud storage space that allows you to access and share your files from your 

desktop, browser, or mobile device.  

I already have a OneDrive account for personal use. How does that integrate with 

OneDrive for Business? 
Your personal/non-Commonwealth OneDrive account is separate from your Commonwealth OneDrive 

for Business account. They do not integrate. 

How long can a file pathway be? 
The entire path, including the file name, must contain fewer than 400 characters. 

Saving and Storage 

Why should I store documents in OneDrive for Business?  
Storing your documents in OneDrive for Business allows you to access your files from any device that is 

connected to the internet. 

In other words, if you were to not have your work computer for any reason, you can still access your 

files from any other computer or mobile device. Your files are safe since they are stored in the cloud. 

How much space do I get?   
Each user gets 1TB of space. There is currently 100GB per file limit. We recommend that the maximum 

number of individual items (files, folders, etc.) synced does not exceed 300,000 for optimal performance 

across all synced libraries. 

Are any documents excluded from the 1 TB limit?  
All documents in OneDrive for Business count towards the storage limit.  

How do I save files in OneDrive for Business?  
You will save files to OneDrive for Business like you normally save files. The difference is that, now, you 

will save files to your “OneDrive” folder rather than your PC folder or home network drive. To do this, 

select File > Save as > OneDrive for Business. You can create folders and structure your OneDrive for 

Business storage space just like you did before on your local network drive or PC. 

What is considered a large file? 
Any file that is 15 GB or higher. Files between 15 GB and 100 GB will have to be manually copied over. 

There is no action needed from the individual user unless stated otherwise. 

Can I store my .pst files in OneDrive for Business? 
If the .pst file is less than 15GB, and not connected to your mailbox, you can store the file in OneDrive 

for Business for archival purposes. 

However, this is not recommended since restoring it may create a corrupt data file, making it unusable 

and potentially causing blockers for the sync client. 



If you need assistance with moving a .pst file out of OneDrive, please refer to this article for more help. 

How can I backup all my .pst files if not in OneDrive? 
You may copy a .pst into your OneDrive folder to back it up for archival purposes, but do not open it in 

Outlook. 

Can I drag and drop files from OneDrive to SharePoint and vice versa?   
You can easily move files from OneDrive for Business to SharePoint. Simply, go to your OneDrive folder 

on your desktop, drag the specific file from your File Explorer window and “drop” it into your SharePoint 

folder in your browser window. 

From OneDrive Online, you can right-click on a document, select Move to, and a list of SharePoint sites 

will appear in a pane on the right. Choose the site you want to move the file or folder. You will see the 

folders within that site. Choose the folder you want to move the file to and select Move here. 

Version History 

If a document auto-saves, how do I get back to the previous version in the browser? 
You can revert to the previous version of a document in your browser by following these steps:   

• Right-click the document you want to restore an earlier version of and click Version History. If in 

the document already, go to File > Info > Version History 

• In the Version History dialog box, select the version of the document that you want to restore, 

and then click Restore. 

Can I revert to previous version in OneDrive Desktop? 
You can view or restore previous versions from the document itself (with the document open, go to File 

> Info > Version History. The document must be saved to OneDrive for this to work properly.) 

You can also right-click on the file name while in File Explorer and select Version History. 

Will version history be available for shared documents (i.e. to see who edited when)?  
Yes, documents shared through OneDrive and SharePoint provide a version history of who edited the 

document and when. Version history will be provided whether the document was shared or not. 

Sharing and Privacy 

Can others see my OneDrive for Business files?  
No, not unless you give them permission to. The files and folders you save in OneDrive for Business are 

private until you decide to share them, and you can stop sharing them at any time. You can also 

determine the level of access they have, such as read-only or editing permissions.  

How are files shared in OneDrive for Business?   
Files are not shared by default. When you upload a file to OneDrive for Business, only you can see it until 

you share it with another user or user group (such as uploading the file to a Teams Channel).   

https://support.microsoft.com/en-us/office/how-to-remove-an-outlook-pst-data-file-from-onedrive-b6b9e522-59bd-40f7-949f-168d0aa9b38e


To share a file or folder, you can simply right-click on the item and select Share. You can do this in 

OneDrive online or OneDrive on your desktop. A popup will then open where you can type in the name 

of the colleague(s) you would like to share the folder or file with.  

Learn about other sharing options in this video. Note that some options may differ from what you see in 

the video and what is enabled for your organization. 

If I share with one person, does it notify the rest of the people who the document has 

already been shared with? 
When you share a document with someone, only you and the person who it was shared with will see the 

request. Other colleagues will not see who else it was shared with. 

Why should I share links to my OneDrive for Business files instead of sending an 

attachment via email?  
Sending attachments of a file, instead of a link, sends a different version of that file to each recipient. So, 

every time a recipient makes a change to that file, they must save a new copy of it, leading to multiple 

drafts and lack of organization. 

Sharing a link to the file using OneDrive for Business allows recipients to collaborate on the same file, 

together. It maintains one version of the document and has version history which allows you to restore 

a prior version (instead of multiple drafts), if needed. This method saves time, storage and is more 

organized. 

Who can I share files with? 
You can share the contents of files stored in OneDrive for Business with colleagues within 

Commonwealth, or with external people once you specify the correct settings. 

Remember that a user can download any file you share with them to their own device. This would be no 

different than if you were to send an email attachment, as you do currently. To prevent a user from 

downloading the document to their device, when you go to share the document, select “People in 

Commonwealth with the link” > uncheck the box that says “Allow editing” > turn the toggle for “Block 

Download” to on. 

How do I share with external recipients? 
Right-click on the file, select Share. When choosing the settings for your file, select “People in 

Commonwealth with the link” > click Specific People > click Apply > click in the box where it says “Enter 

a name or email address” > enter the email address(es) of the recipient(s). 

Remember that a user can download any file you share with them to their own device. This would be no 

different than if you were to send an email attachment, as you do currently. To prevent a user from 

downloading the document to their device, when you go to share the document, select “People in 

Commonwealth with the link” > uncheck the box that says “Allow editing” > turn the toggle for “Block 

Download” to on. 

If I share a document, how do I get a list of permission level by person? 
In OneDrive, right-click on the document > Details. A pane will open that displays the users under the 

“Has access” section. Click on the Managed access link to see the list of users with access and the 

https://youtu.be/Z6qpwTI5lRI


corresponding permissions assigned to them. Click Advanced in the bottom-right corner of the pane 

window to see more details. 

Can I send a OneDrive for Business file to someone who does not have Office?  
Yes. When you send a OneDrive for Business file to someone who does not have Office, it will open the 

file in the free web version of the Office application and allow the user to make edits. 

Syncing 

What do the icons under the “Status” column mean in my OneDrive folder in File 

Explore? 

 

Online-Only File: A blue cloud icon next to a OneDrive file or folder means 

that the file is only available online, so it does not use up your device’s 

storage. You must be connected to the internet to open this type of file. 

 

Locally Available File: You can open this type of file at any time, even without 

internet access. If you need more space, you can change the file back to online 

only by right-clicking on the file and selecting “Free up space.” 

 

Always Available Files: Only files that you mark as "Always keep on this 

device" have the green circle with the white check mark. These files 

download to your device and take up space, but they’re always there for you 

even when you’re offline. 

 

What happens if I delete a file? Can it be recovered?  
If you delete a file stored in OneDrive for Business, it will be in your recycle bin for 3 years. After that, it 

is permanently gone. 

Can I work on my files if I am not connected to wi-fi?  
Yes, you can work on files from your OneDrive for Business client without being connected to wi-fi. Your 

work will be saved but not uploaded to OneDrive until you are connected to wi-fi again. Once connected 

to wi-fi again, your work will automatically upload to your OneDrive client. 

Why will my file not sync? 
It may be your file name. The following characters are not allowed in file and folder names in OneDrive 

or SharePoint: " * : < > ? / \ | 

Another reason may be due to a lack of network connection. 

Co-Authoring 

Will I receive a notification that an edit has been made?  
There are no automated notifications, but a record of edits is tracked through version history along with 

other review options under the Review tab when the file is opened. 



Does the document owner have to approve changes that are in conflict?   
When conflicts exist, the document owner is notified either in a message bar or another notification. 

You can click any of the notifications to work in “Conflict Resolution” mode and resolve all conflicting 

changes. In Conflict Resolution mode, a “Resolution” pane appears and lists the conflicts.  

Simultaneously, the Conflict tab appears on the Ribbon. When you click a conflicting change in the pane, 

the conflicting portion of the document is highlighted. The conflicting changes are automatically marked 

up in another color. In the Conflict tab, click Accept to keep the change or Reject to remove the change. 

When you are working on a document shared with users offline, how are concurrent 

changes merged?   
Working offline: Multiple people can work separately on a document while offline. When one person 

goes online (connects to the internet), their edited copy becomes the file of record. Now, when another 

person goes online, and they have made changes to the same document, the previous copy gets 

overwritten. The owner can see the history and decide what version to go with. 

Working online: If multiple people are co-authoring online, you can see the cursor location where 

someone is working and what they are typing as they type, just as if they are working on your computer 

or device with you. You can see where that person is working in the document almost instantly and 

hover over the cursor location to see their name as they make the changes. 

Can you print off co-authored documents without the comments?  
Co-authored documents can be printed off with or without comments. Go to File > Print > click on the 

box that says, “Print All Settings” to display the dropdown menu. Deselect Print Markup by clicking on 

the “Print Markup” statement at the bottom. 

Managing Files in OneDrive 

How can I select multiple files in OneDrive for Business Online? 
You can select each file by clicking on the circles next to each file name in OneDrive Online.  

If there is more than one file you’d like to select, select the circle to the left of that file name > hold 

down the CTRL button on your keyboard > select the circle(s) next to the file name(s) of the other file(s) 

you want. 

When searching for a document, does it search by the document title only or all parts of 

the document (subheadings, body, etc.)?  
The search function in OneDrive for Business searches both document titles as well as words within the 

documents (subheadings, body, etc.) 

  



Why is OneDrive automatically renaming my file? 
When the file name you provide contains invalid characters, OneDrive sometimes renames it for you. 

This may occur if your file name contains: 

• A space at the beginning or end of the file name 

• A period, unsupported Unicode code points, or surrogate pair issues at the end of the name 

What is the process for off-boarding files?  
Removal of working files in OneDrive for Business is at the discretion of each colleague. For SharePoint, 

a consultation with the SharePoint admin should occur before any files are removed. 

What happens to OneDrive files if a colleague leaves the organization?  
The colleague’s manager may request access to the colleague’s files. 


