eDEP System & Browser Requirements

System and browser requirements for using eDEP

Using eDEP on Windows PC

Most eDEP forms require Adobe Reader to display. Adobe updates this product frequently, so some Reader versions may not currently be compatible with eDEP. 

eDEP is confirmed to work on the following:

  • Windows 7 with Firefox 38
  • The latest version of Reader 11 (11.0.11)
  • Internet Explorer 8 using previous Adobe Reader 11.0.

Various systems and adobe versions may be compatible with eDEP. The ones listed above are tried and tested.

Additional Resources for Using eDEP on Windows PC

Using eDEP on Macintosh

eDEP on Mac works best with:

  •     Safari up to Version 11
  •     macOS up to version 10.13.4

Various systems and adobe versions may be compatible with eDEP. The ones listed above are tried and tested.

eDEP Account Security

eDEP has added features to make your account more secure and easier to manage. The system will prompt you to review and accept the revised Terms and Conditions, so you can set-up your security questions. 

The security questions help confirm your identity whenever you make changes to your profile or reset your password. After setting-up your security questions, you will be able to reset your password automatically. 

In some cases, you may also need to answer a security question when you sign your form. Certain forms are now subject to federal requirements for this additional verification. 

However, if you are completing a form that does not require such verification, then you will see no change when signing your form.

Feedback